Where do I find ld.so?

a.out applications like Netscape Navigator require a.out libraries. A version of FreeBSD built with ELF libraries does not install them by default. You will get complaints about not having /usr/libexec/ld.so if this is the case on your system. These libraries are available as an add-on in the compat22 distribution. Use sysinstall(8) to install them. You can also install them from the FreeBSD source code:

    # cd /usr/src/lib/compat/compat22
    # make install clean

If you want to install the latest compat22 libraries whenever you run make world, edit /etc/make.conf to include COMPAT22=YES. Old compatibility libraries change rarely, if ever, so this is not generally needed.

Also see the ERRATAs for 3.1-RELEASE and 3.2-RELEASE.



UNIXguide.net
Suggest a Site