How do I build programs under a later AIX release that run under earlier releases as well?


IBM develops AIX only for binary compatibility with older AIX releases,
not the other way around. You will thus need to build programs on the
oldest AIX release the program is supposed to run on. You will also need
to link programs dynamically, if you link in the system libraries
statically the program will probably only run on the machine you
performed the link on.

With some preparation it is appearently possible to get around that
limitation. Bob Halblutzel has put together a web page describing the
detailed steps how to set up such a build environment at the following
web page:



Please not that this is not a supported way to build your programs, you
will probably receive not any support by IBM if you have problems with
that environment.



UNIXguide.net
English to Visayan Cebuano Dictionary

Find: Display: hits per page

Suggest a Site
Visayan Cebuano to English Dictionary