Can I use the source compatibility package to postpone porting?



Not really. The Source code compatibility package is
compatible with BSD 4.2, not SunOS 4.1.x. The consensus
is that the library is broken beyond usability.
If you use libucb to pick up some functions you need, it
is often best to specify it after all other libraries and
after libc with:



-lc -L/usr/ucblib -R/usr/ucblib -lucb


or preferably:



-lc /usr/ucblib/libucb.a





UNIXguide.net
Suggest a Site